TikaとPOI

POIが悪いのかもしれないけど、Tikaは利用しているPOIのバージョンが違うと動かなくなる…。たとえば、Tika 1.0でPOI 3.8-beta5を使おうとすると、Exceptionが発生する。Tikaで利用するPOIのメソッドが見つからない的なエラーになる感じ。今までにも同じようなパターンでPOIのバージョンをTikaが使っているもの以外にすると、度々この問題に遭遇した。POIがもっと互換性を考えてくれれば発生しないと思うだけどね。もしかしたら、POIはbetaだから変えてもいいだろう的な感じなのかもしれないけど、不便な感じだ。

カテゴリー: Apache タグ: , パーマリンク

コメントを残す

メールアドレスが公開されることはありません。

Time limit is exhausted. Please reload the CAPTCHA.