yumでパッケージの強制更新

yumでパッケージの強制更新をしたかったけど、オプションなどが見つからず、どうすればいいのか調べたけど、結局はrpm --forceみたいな感じになるっぽい。たとえば、perlパッケージを強制更新したかったら、

# yumdownloader perl

でパッケージをダウンロードして、

# rpm -Uvh --force perl-5.8.8-38.el5.x86_64.rpm

という感じで、rpm による強制更新をしてしまう。もし、yumdownloaderがなかったら、

# yum install yum-utils -y

という感じでインストールしておく。

カテゴリー: Linux パーマリンク

コメントを残す

メールアドレスが公開されることはありません。

Time limit is exhausted. Please reload the CAPTCHA.